Incorrect URL When Using a Multilingual SharePoint Blog Site

I recently encountered a relatively puzzling circumstance on a multilingual blog site. In this scenario, the customer was using the SharePoint blog as part of their public facing web site and while the English site was working fine, the French site was not. More accurately, I should state that it wasn’t working for me, but I’ll get to that shortly.

For the most part, the French blog site was working. The posts showed up on the main page, and could be accessed. However, if you opened up the source list for the posts, either by using “All Content” or by selecting “Manage Posts”, the posts would appear, but clicking on them would result in the error “Page not found – The page you’re looking for does not exist”.

The first clue was that although the list is named “posts”, the site itself is a French site, so the actual list name is “Billets” as seen below.

SNAGHTML1a423938

This difference is a feature of SharePoint 2013, and it happens because this is a multilingual site that has been enabled for multiple language display. In my case, my user profile identifies my preferred language as English, and SharePoint automatically translates all system generated text into English. With this feature, an English system administrator can easily navigate a French site because pages like system settings are automatically translated.

Unfortunately, in the case of the blog site, the translation system gets a little overzealous. Clicking on one of the blog posts from the system view results in the error mentioned above. Why is there an error? All we need to do is to look at the URL to discover the reason.

SNAGHTML1a4988fc

As you can see, the list name requested is “Posts” but we know that the actual name is “Billets”. The URL itself is being translated for me. So how do we avoid this problem?

As good as the translation system is, it’s not worth the error, so we need to turn it off for this site. Doing so is as simple as turning it on. From the Site settings page, select “Language settings” under the Site Administration section.

image

From there, simply deselect all alternate languages, and automatic translation will no longer be performed.

image

Once this is done, the URL will no longer be translated, and opening posts will work. You will now need to navigate the site settings in a different language, and know that “Language settings” is the same as “Paramètres linguistiques”, but most SharePoint admins can navigate here with their eyes closed anyway.

I hope that this helps.

3 thoughts on “Incorrect URL When Using a Multilingual SharePoint Blog Site”

  1. Run into the exact same problem, however our site and users are REALLY multilingual so I cannot afford disabling translation.

    What is this dumb idea to translate content URL ? Hello Microsoft ?

  2. Solution:

    C:Program FilesCommon Filesmicrosoft sharedWeb Server Extensions15Resourcescore.fr-fr.resx

    Modify “blogpost_Folder »

    Billets

    ==>

    Posts

    (in our case default language is english, additionnal is French among others).

    Then recycle application Pool.

  3. Hi guys! If you ever need an online resource where you can read useful information about localization, translation and other related topics, I suggest you have a look at this website: http://l10nhub.com/. Thanks!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.